viernes, 11 de mayo de 2012

Capitulo 8. Programación Justo a Tiempo - Parte I


1.        Introducción

La programación "justo a tiempo" (Just In Time: JIT), llamado también “producción frugal”, es un conjunto de técnicas de programación de operaciones, que pretende que los clientes sean servidos:

-   Justo en el momento preciso
-   Exactamente en la cantidad requerida
-   Con productos de máxima calidad
-   Mediante un proceso de producción que utilice el mínimo de personal, de materiales, de espacio, de tiempo y de inventario (de materia prima, productos en proceso y productos terminados)
-   Que se encuentre libre de cualquier tipo de despilfarro o coste innecesario.

2.        Nivelado de la Producción

Bajo la filosofía "Justo a tiempo", la empresa se prepara para conseguir que la producción y, consiguientemente, los recursos que ésta emplea, se distribuyan de la forma más uniforme posible a lo largo del tiempo.
En el caso de una línea de montaje dedicada a obtener un cierto grupo de productos finales, la nivelación debe adoptar un método que permita nivelar la producción a la demanda variable, de tal manera que una línea no fabrique un tipo único de productos en grandes lotes, sino que produzca muchas variedades diarias en pequeños lotes, con lo que se conseguirá, además, una rápida adaptación a la demanda cambiante de los consumidores.

2.1.  Fases del Nivelado de la Producción

a)        Adaptación mensual, que expresa la adaptación a los cambios de la demanda durante el año (programa maestro de producción).
b)        Adaptación diaria, que expresa la adaptación a los cambios diarios de la demanda durante el mes (programa de montaje final).

Los Programas Maestros de Producción (PMP) suelen tener un horizonte temporal de tres a seis meses.
Su revisión suele ser mensual, ya que este programa debe contar con mayor nivel de detalle cuánto más cercano esté el mes planificado del momento actual.

3.        Programa Maestro de Producción

Así, mientras que en los meses más lejanos la producción esta agregada por familias, a medida que nos acercamos al momento actual, los periodos de tiempo y/o las cantidades se desagregan.
Uno de los aspectos más importantes que se derivan del PMP es la tasa media diaria de fabricación para el proceso productivo (producción del periodo/días laborables del periodo).
Por ejemplo, el programa maestro de producción para una línea de montaje dispone de un periodo de un mes, con 20 días laborables.
En la línea se trabaja en un doble turno (de ocho horas cada uno).
De dicho tiempo se debe descontar 15 minutos diarios, empleados en el cambio de turno.
La demanda mensual de cierta familia de productos es de 10500 unidades que, desglosadas por productos, queda tal como se indica en la siguiente tabla:

Cuadro 1. Datos del problema.


Determinar el tiempo de ciclo y la producción por ciclo de cada producto.

Cuadro 2. Solución del Ejemplo de PMP


(1)     Hallar los minutos disponible diario para labores de fabricación (E13)
(2)     Dadas las necesidades de fabricación y los días disponibles conseguir un programa nivelado implica hallar una tasa media diaria de fabricación (E9).
(3)     Determinar la fabricación diaria para cada producto (B9)
(4)     Calcular el ciclo de fabricación del sistema, que es el periodo de tiempo que transcurre entre la salida de dos productos finales (E14)
(5)     Para hacer frente a la demanda diaria, cumpliendo, a su vez, los objetivos propuestos para los programas nivelados, determinar el tiempo de ciclo de fabricación para cada producto (B10)
(6)     Determinar el tiempo de ciclo de fabricación más largo de los calculados en el paso anterior (E12).
(7)     Hallar la producción por ciclo en unidades (B11).
(8)     Determinar la producción total por ciclo en unidades (E11).

Un posible Programa de Montaje Final nivelado podría ser el que implicase la fabricación de la siguiente secuencia de productos finales: AAAABCC, la cual debería repetirse hasta terminar los productos programados.

3.1.       Plan de Materiales

A partir del programa maestro de producción, y con la ayuda de la lista de materiales, se realiza una explosión de las necesidades con el objeto de advertir a los distintos responsables de los centros de trabajo, finales o intermedios, así como a los supervisores de aprovisionamiento, sobre las necesidades que van a sufrir en un próximo futuro.
Los responsables de cada puesto utilizarán estos programas para prepararse en cuanto a mano de obra, materiales, componentes, mantenimiento productivo, etc.
Si, una vez evaluado, el plan no resulta viable en cualquier parte de la empresa, los planificadores deberán replantearlo.

4.        Programa de Montaje Final

Para lograr el consumo nivelado de recursos se usa una técnica que permite programar la secuencia para cada periodo, que indique el orden de montaje de los diversos productos a través de las líneas de montaje.
¿Cómo se determina la secuencia de fabricación?
Por ejemplo si se requieren fabricar los productos A, B, C y D, suponer que la secuencia actual es: AAAABBBCCD.
La meta de este programa consiste en encontrar una secuencia, que podría ser más complicada, tal como: ABACBADABC, pero que es óptima por que mantiene constante la velocidad de consumo de cada material.

4.1.       Algoritmo de Persecución de Objetivos

Esta secuencia se calcula con la ayuda del Algoritmo de Shigenori Kotani (1982), más conocido como Algoritmo de Persecución de Objetivos (APO)
El objetivo de este algoritmo consiste en minimizar la diferencia entre la cantidad    promedio del material j programada para consumir hasta el número de secuencia k y la cantidad real consumida del material j hasta la secuencia k.


Notación

P                  :    Cantidad total de productos a fabricar en cada ciclo de secuencias nivelado
N[j]              :    Cantidad total requerida de materiales j, en todos los procesos
N[j] / P         :    Consumo promedio del material j programado para cada número de secuencia
k * N[j] / P   :    Consumo promedio acumulado del material j programado hasta el número de secuencia k
B[i][j]           :     Cantidad requerida del material j para fabricar una unidad del producto i
X[j][k‑1]      :     Consumo real acumulado del material j hasta el número de secuencia anterior a k
X[j][k]         :     Consumo real acumulado de material j hasta la secuencia actual (k) en producto i. Es decir:
                          X[j][k] = X[j][k‑1] + B[i][j]

Cuadro 3. Diferencia entre Consumo Promedio y Consumo Real Acumulados



Ejemplo del APO

Determinar la secuencia de operaciones nivelada usando las producciones por ciclo obtenidas en el PMP del ejemplo anterior.
Por otro lado, suponer que el departamento de I&D ha determinado la siguiente lista de materiales:

Cuadro 4. Requerimiento de materiales.


Solución del Ejemplo del APO

El procedimiento es el siguiente:

(1)   Ingreso de datos al algoritmo:
L       :    Número de tipos de productos a fabricar
M      :    Número de tipos de materialesQ[i] : Producción por ciclo para el producto i         (i=1..L)
B[i][j]  :           Cantidad requerida del material j (j=1..M) para fabricar una unidad del producto i

Cuadro 5. Cálculo de la producción por ciclo.


 
(2)   Calcular los requerimientos totales de cada material j para un ciclo:
 
 
(3)   Calcular la producción en cada ciclo de la secuencia nivelada:

(4)   Calcular el consumo promedio del material j programado para cada número de secuencia:

                                                                R[j] = N[j] / P

 
(5)     Calcular la secuencia de producción nivelada.

El procedimiento heurístico a realizar es el siguiente:
En el rango B12:B16 asignar los valores iniciales del consumo real acumulado del material j hasta la secuencia anterior (k‑1)

            X[j][k‑1]=0

PRIMERA ITERACION:

a)        Calcular el cuadrado de la diferencia de consumos promedio y real del k‑écimo montaje del producto i:

       D[k][i][j] = (k*R[j] ‑ X[j][k‑1] ‑ B[i][j])2

 Cuadro 6. Cálculo de las secuencias de producción nivelada (primera y segunda iteración).



b)    Calcular la raíz cuadrada de la suma de las diferencias encontradas en el paso anterior.



c)    Calcular la diferencia mínima del k‑écimo montaje:




d)    Determinar el producto seleccionado, cuyo subíndice será asignado a:  z[k] = i


e)    Calcular el consumo real acumulado del material j hasta la secuencia actual (k) en el producto z[k]:

X[j][k] = X[j][k‑1] + B[z[k]][j]

Repetir este procedimiento hasta terminar la secuencia, es decir hasta que k>P.

Fórmulas de la Segunda Iteración:

G12:    =($H$10*$F3-$F12-B3)^2
G17:    =RAIZ(SUMA(G12:G16))
I18:      =MIN(G17:I17)
I19:      =SI(G17=I18;B2;SI(H17=I18;C2;D2))
J12:     =SI(I$19=$B$2;F12+$B3;SI(I$19=$C$2;F12+$C3;F12+$D3))


Fórmulas de la Tercera Iteración:

K12:    =($L$10*$F3-$J12-B3)^2
K17:    =RAIZ(SUMA(K12:K16))
M18:    =MIN(K17:M17)
M19:    =SI(K17=M18;B2;SI(L17=M18;C2;D2))
N12:    =SI(M$19=$B$2;J12+$B3;SI(M$19=$C$2; J12+$C3;J12+$D3))

Fórmulas de la Cuarta Iteración

O12:    =($P$10*$F3-$N12-B3)^2
O17:    =RAIZ(SUMA(O12:O16))
Q18:    =MIN(O17:Q17)
Q19:    =SI(O17=Q18;B2;SI(P17=O18;C2;D2))
R12:    = SI(Q$19=$B$2;N12+$B3;SI(Q$19=$C$2;N12+$C3;N12+$D3))


Cuadro 7. Cálculo de las secuencias de producción nivelada (tercera y cuarta iteración).




Fórmulas de la Quinta Iteración:

S12:     =($T$10*$F3-$R12-B3)^2
S17:     =RAIZ(SUMA(S12:S16))
U18:    =MIN(S17:U17)
U19:    =SI(S17=U18;B2;SI(T17=U18;C2;D2))
V12:    =SI(U$19=$B$2;R12+$B3;SI(U$19=$C$2;R12+$C3;R12+$D3))

Fórmulas de la Sexta Iteración

W12:   =($X$10*$F3-$V12-B3)^2
W17:   =RAIZ(SUMA(W12:W16))
Y18:    =MIN(W17:Y17)
Y19:    =SI(W17=Y18;B2;SI(X17=Y18;C2;D2))

Z12:     =SI(Y$19=$B$2;V12+$B3;SI(Y$19=$C$2;V12+$C3;V12+$D3))


Cuadro 8. Cálculo de las secuencias de producción nivelada (quinta y sexta iteración).



Fórmulas de la Sétima Iteración

AA12: =($AB$10*$F3-$Z12-B3)^2
AA17: =RAIZ(SUMA( AA12:AA16))
AC18:  =MIN(AA17: AC17)
AC19: =SI(AA17=AC18;B2;SI(AB17=AC18;C2;D2))
AD12: =SI(AC$19=$B$2;Z12+$B3;SI(AC$19=$C$2;Z12+$C3; Z12+$D3))

Cuadro 9. Cálculo de las secuencias de producción nivelada (sétima iteración).



Basándonos en los cálculos anteriores se obtiene el siguiente cuadro resumen:

Cuadro 10. Programa de secuencias de producción nivelada.


* Indica distancia mínima D[k,i]


(6)  Mostrar gráficamente los resultados obtenidos usando el siguiente procedimiento:

a)        Usar las siguientes fórmulas para tabular los consumos reales de material j hasta el producto k:

B31:    =B12
C31:    =F12   
D31:    =J12
E31:     =N12              
F31:     =R12
G31:    =V12              
H31:    =Z12
I31:      =AD12

Copiar estas fórmulas hasta la línea 35.

 Cuadro 11. Cálculo de los consumos reales y promedio.



a)        Usar la siguiente fórmula para tabular los consumos promedios del material j hasta producto terminado k:

B37:    =B$29*$F3
Copiar la fórmula anterior hasta la celda I41.

b)        Graficar los consumos promedios y reales para cada uno de los materiales, ubicando en las abscisas el número de producto terminado y en las ordenadas los consumos.

 Cuadro 12. Consumos reales y promedios de cada material.






No hay comentarios:

Publicar un comentario en la entrada